Wiki-translation discussion Help

Forums > Wiki-translation discussion> Problems with Tiki structures + Translations

Problems with Tiki structures + Translations

ricks99 United States
As a follow-up to this thread... I've done some investigation and testing with TikiWiki wiki structures with Translation. I'm posting my results here in hopes that someone can verify my findings...

My test site: http://keycontent.org/i18ntest/tiki-index.php, running Tiki 1.10SVN with the Multilingual and Multilingual structures options enabled.

The site contains the following wiki structure:
My Structure (EN and DE)
  • Page One (EN, ES and DE)
    • Page Two (EN)
      • Page Three (EN and ES)
        • Page Four (EN)
      • Page Five (EN and DE)
    • Page Six (EN)


Switching Languages Breaks the Structure

With the site language in EN:
  1. Click Structure from the menu.
    • You get the Structure showing the EN pages, as expected.
    • Tiki informs you of a DE version
  2. Go to Page One.
    • You remain in the EN structure.
    • Tiki informs you of a ES and DE version
  3. Switch to the Spanish version (by using either the Language drop list from the wiki page or the Page Translation module).
    • You are now on the Spanish version of the EN page, as expected

      But you are no longer in the structure

The problem:
  • When switching the language, Tiki needs to append the &structure=Foo information to the URL.



Using the Open Page As Structure option

^When I enable the wiki _Open page as structure feature, I get the following:
With the Site Language as English:
  1. Click First Page from the menu.
    • Tiki opens Page One, as a structure.
    • Tiki informs you of a ES and DE version
  2. Switch to the Spanish version (by using either the Language drop list from the wiki page or the Page Translation module).
    Nothing happens. Tiki still shows the EN page
The problem: Tiki does not allow me to switch to a translated page if the "Open page as structure" option is enabled.

I don't know if these should be logged here, or on the TikiWiki dev site.

Thanks

-R

There are quite a few issues everywhere in tiki with structure being lost as you navigate. I didn't try to fix those. In fact, I believe most of the structure code has to be rewritten anyway.

As for the language suggestion, I don't think it looks at the language of the page you are looking at at this time. It only looks at the site language and your different language preferences. I didn't do extensive tests, but it did seem to work on my site.

I will try to find some time to look into it.


Hi,
i have the same "problem" on version 2.1. Is there any workaround/solution available?
br
non

> Hi,
> i have the same "problem" on version 2.1. Is there any workaround/solution available?
> br
> non

Not at the moment, sorry.

Alain D├ęsilets


Show posts:
Jump to forum:

Upcoming Events

No records to display